Introduction

Recently I needed to configure trunking between a group of DELL M1000e blade chassis systems (with a mixture of switch modules) and one of our core Procurve 5406 Switches.

The switch modules in the first Blade chassis consisted of 6x M6220’s which I configured as a single stack using the stacking modules. While one of the other Blade Chassis has 6x CISCO 3130X installed (also stacked). All up we have 4 M1000e chassis’s.

The blade servers vary between M610, M710, M805 and M905 servers, Each has a mixture of ethernet ports due to mezzanine cards installed but a typical config for an ethernet port in the M6220 switches looks like:


interface ethernet 2/g1
switchport access vlan 200
exit

M6220 Configuration

To get the M6220 to trunk to the HP, the trunk interface was setup as an LACP Link Aggregation Group (LAG) which both the M6220 and the HP Procurve 5406 natively support. In the example below 2 VLANS are sent down the trunk.

!
interface port-channel 1
description ‘LAG-1’
hashing-mode 1
switchport mode trunk
switchport trunk allowed vlan add 130,200
exit

There are 2 ports on switch setup in trunk mode back to the HP switch. The ports are 19 and 20.

!
interface ethernet 2/g19
channel-group 1 mode auto
description ‘HPTrunk1’
switchport mode trunk
switchport trunk allowed vlan add 130,200
exit
!
interface ethernet 2/g20
channel-group 1 mode auto
description ‘HPTrunk2’
switchport mode trunk
switchport trunk allowed vlan add 130,200
exit

Originally the vlans were added to the ports not the trunk, but this did not appear to work most of the time, so they were configured at the trunk level and all worked perfectly.

HP Procurve 5406 Config

The HP config is very simple, first, define LACP active on the ethernet ports (in this example its ports A1 and A2):

   config t
   interface A1
   lacp active
   exit
   interface A2
   lacp active
   exit

Then define the trunk:

   config t
   trunk a1-a2 Trk1 lacp
   exit

Next associate the trunk into the required VLANs, this is done using the “tagged” command. Note that a normal ethernet port is usually setup as “untagged”.

    config t
    vlan 200
    tagged trk1
    exit

    vlan 130
    tagged trk1
    exit
    exit

Lastly, plug the cables into ports A1 and A2, I suggest using cross over cables so the switches connect together at the highest speed automatically. Then, on the procurve, use the CLI command:

   show lacp

and

   show trunk

The trunk should now be up and packets routing between the ethernet ports in their respective trunked VLAN ‘s.

 

Advertisements